Questo sito utilizza cookie, anche di terze parti, per migliorare la tua esperienza e offrire servizi in linea con le tue preferenze. Chiudendo questo banner, scorrendo questa pagina o cliccando qualunque suo elemento acconsenti all’uso dei cookie

Rimani informato sugli aggiornamenti di SOS-OFFICE. Inserisci il tuo indirizzo e-mail: Informativa sulla privacy

In Calc, la funzione CONTA.SE (COUNT.IF in Inglese) ci permette di effettuare un conteggio condizionale ovvero determinare il numero di celle il cui valore rispetta il criterio di selezione indicato.

La sintassi della funzione è la seguente:

CONTA.SE(Intervallo; Criterio) dove Intervallo indica l'insieme di celle da considerare per il conteggio e Criterio indica appunto il criterio da usare per l'analisi dei valori.

Il criterio è l'elemento chiave. Esso può essere semplice come

">10"

che significa prendi tutte le celle il cui valore è maggiore di zero.

Nota: facciamo attenzione ad indicare il criterio tra le virgolette perché, in assenza di esse, il criterio sarebbe interpretato da Calc come espressione booleana prima della esecuzione della funzione CONTA.SE.

Il criterio può fare riferimento al valore di altre caselle. Ad esempio:

=CONTA.SE(B2:B100;">="&E3)

il criterio qui è costruito sulla base del valore della cella E3. Vengono contate tutte le celle il cui valore è maggiore o uguale a quello di E3.

Possiamo usare anche le espressioni regolari:

=CONTA.SE(A1:A14;"I.+")

che indica conta tutte le celle il cui valore inizia per la lettera "I".

Maggiori riferimento si possono trovare su

Joomla templates by a4joomla