Questo sito utilizza cookie, anche di terze parti, per migliorare la tua esperienza e offrire servizi in linea con le tue preferenze. Chiudendo questo banner, scorrendo questa pagina o cliccando qualunque suo elemento acconsenti all’uso dei cookie

Rimani informato sugli aggiornamenti di SOS-OFFICE. Inserisci il tuo indirizzo e-mail: Informativa sulla privacy

Benvenuto, Ospite
Nome utente: Password: Ricordami

ARGOMENTO: PROBLEMI CON CERCA.VERT

PROBLEMI CON CERCA.VERT 1 Anno 9 Mesi fa #460

  • CARBEN
  • Avatar di CARBEN
  • Offline
  • Fresh Boarder
  • Messaggi: 9
Buona sera, ho un problema con la funzione CERCA.VERT.
nel file allegato, sul foglio 1 ho dei codici fiscali/partita iva, e sul foglio 2 ho nella prima colonna "A" i codici fiscali/partita iva, e vorrei che sulla colonna "B" del foglio 1 mi si riportino i POD del foglio 2. Ma ho notato che mi restituisce i valori in modo errato. la formula che inserisco nella colonna "B" del foglio 1 è:
=CERCA.VERT(A1;Foglio2!$A$1:$B$120;2;VERO).
in cosa sbaglio?
faccio presente che questo è solo un esempio, di solito nel foglio 1 ho circa 1.000.000 di righe, con relativi dati POD e Altro (una ventina di colonne) e nel foglio 2, 500.000/700.000 codici fiscali da controllare ed abbinare al POD.
mi potreste dare una mano? ve ne sarei molto grato.
molte grazie.

This message has an attachment file.
Please log in or register to see it.

L\'Amministratore ha disattivato l\'accesso in scrittura al pubblico.

PROBLEMI CON CERCA.VERT 1 Anno 9 Mesi fa #461

mi pare di capire che cerchi dei valori precisi, dunque l'ultimo argomento della formula deve essere Falso oppure 0, non vero.
L\'Amministratore ha disattivato l\'accesso in scrittura al pubblico.

PROBLEMI CON CERCA.VERT 1 Anno 9 Mesi fa #462

  • CARBEN
  • Avatar di CARBEN
  • Offline
  • Fresh Boarder
  • Messaggi: 9
se ad un codice fiscale corrispondono più POD diversi, come fa il cerca.vert a distinguerli e mostrarmeli?
grazie
L\'Amministratore ha disattivato l\'accesso in scrittura al pubblico.

PROBLEMI CON CERCA.VERT 1 Anno 9 Mesi fa #463

Non è possibile
bisogna usare una combinazione di formule in forma di matrice
L\'Amministratore ha disattivato l\'accesso in scrittura al pubblico.

PROBLEMI CON CERCA.VERT 1 Anno 9 Mesi fa #464

  • CARBEN
  • Avatar di CARBEN
  • Offline
  • Fresh Boarder
  • Messaggi: 9
grazie.
L\'Amministratore ha disattivato l\'accesso in scrittura al pubblico.

PROBLEMI CON CERCA.VERT 1 Anno 9 Mesi fa #467

  • Rubik72
  • Avatar di Rubik72
  • Offline
  • Utente esperto
  • Messaggi: 56
CARBEN ha scritto:
se ad un codice fiscale corrispondono più POD diversi, come fa il cerca.vert a distinguerli e mostrarmeli?
grazie
io ho controllato il file allegato, ma ci sono codici fiscali duplicati che corrispondono sempre gli stessi POD e non diversi,
altrimenti potresti provare in Foglio1

B2=INDICE(Foglio2!$B$2:$B$120;PICCOLO(SE(Foglio2!$A$2:$A$120=Foglio1!A2;RIF.RIGA(Foglio2!$A$2:$A$120)-RIF.RIGA(Foglio2!$A$2)+1);CONTA.SE(Foglio2!$A$2:A2;Foglio1!A2)))

da inserire con CTRL + SHIFT + ENTER
Follia è fare sempre la stessa cosa e aspettarsi risultati diversi.
Albert Einstein
L\'Amministratore ha disattivato l\'accesso in scrittura al pubblico.
Tempo creazione pagina: 0.160 secondi
Powered by Forum Kunena
Joomla templates by a4joomla