Questo sito utilizza cookie, anche di terze parti, per migliorare la tua esperienza e offrire servizi in linea con le tue preferenze. Chiudendo questo banner, scorrendo questa pagina o cliccando qualunque suo elemento acconsenti all’uso dei cookie

Rimani informato sugli aggiornamenti di SOS-OFFICE. Inserisci il tuo indirizzo e-mail: Informativa sulla privacy

Oggi voglio tornare su un argomento che ho trattato tempo fa e cioè il conto dei valori univoci in un intervallo.

La formula proposta in quel vecchio post (=MATR.SOMMA.PRODOTTO(1/CONTA.SE(intervallo;intervallo))) funziona, ma presuppone che l’elenco in cui contare i valori univoci non contenga celle vuote.

Ecco un esempio in cui vogliamo contare quanti sono i clienti da cui abbiamo ricevuto ordini.

Se proviamo a cancellare in valore di una cella nella colonna C, la nostra formula ci restituisce un errore.

Nel caso di celle vuote, infatti ci ritroviamo con uno 0 al denominatore della divisione…. Di conseguenza l’errore.

È possibile adottare dei correttivi alla formula, ad esempio se desideriamo che le celle vuote siano contate, la formula diventa

=MATR.SOMMA.PRODOTTO(1/CONTA.SE(C2:C49;C2:C49 & ""))

O più genericamente

=MATR.SOMMA.PRODOTTO(1/CONTA.SE(intervallo; intervallo & ""))

 

 

Se, invece, vogliamo ignorare le celle vuote, la formula diventa

=MATR.SOMMA.PRODOTTO((C2:C49<>"")/CONTA.SE(C2:C49;C2:C49 &""))

O più genericamente

=MATR.SOMMA.PRODOTTO((intervallo <>"")/CONTA.SE(intervallo; intervallo &""))

Attachments:
Download this file (Riepilogo ordini.xlsx)Riepilogo ordini.xlsx[ ]13 kB
Joomla templates by a4joomla