Questo sito utilizza cookie, anche di terze parti, per migliorare la tua esperienza e offrire servizi in linea con le tue preferenze. Chiudendo questo banner, scorrendo questa pagina o cliccando qualunque suo elemento acconsenti all’uso dei cookie

Rimani informato sugli aggiornamenti di SOS-OFFICE. Inserisci il tuo indirizzo e-mail: Informativa sulla privacy

Dopo un po’ di tempo (purtroppo), torno con un post in cui voglio mostrare come calcolare con Excel la media ponderata, ossia la media che tenga conto, a differenza della media aritmetica, del peso di ciascun elemento.

Excel non dispone di una funzione specifica per effettuare questo tipo di calcolo, ma occorre ricorrere a due funzioni annidate.

Immaginiamo di aver ordinato 200 scatole di cartone. Non tutte le scatole hanno lo stesso prezzo: il numero delle scatole di ciascun prezzo nel nostro ordine è riassunto nell'immagine seguente.

 

Quanto costa in media ciascuna delle nostre scatole?

Con la media aritmetica potremo calcolare il prezzo medio delle scatole (0,2+0,3+0,1+0,5)/4. In Excel faremmo =MEDIA(B2:B5)

In realtà abbiamo più scatole che costano 0,1 e scatole che costano 0,5 rispetto a quelle che costano 0,2 e 0,3.

Con la media ponderata, possiamo tener conto di questo peso maggiore. Vediamo come:

- si moltiplica ciascun valore per il relativo peso, cioè per la frequenza; (10*0,2) (40*0,3) (80*0,1) (70*0,5)
- si sommano i prodotti ottenuti; (10*0,2)+(40*0,3)+(80*0,1)+(70*0,5) o, in excel, =(A2*B2)+(A3*B3)+(A4*B4)+(A5*B5)
- si divide quindi per la somma delle frequenze ((10*0,2)+(40*0,3)+(80*0,1)+(70*0,5))/(10+40+80+70) o in excel =((A2*B2)+(A3*B3)+(A4*B4)+(A5*B5))/SOMMA(A2:A5)

Non è molto agevole eseguire la prima parte del calcolo (((A2*B2)+(A3*B3)+(A4*B4)+(A5*B5))) se i valori da moltiplicare fra di loro e poi sommare sono molti.

Per semplificare la procedura, possiamo utilizzare la funzione MATR.SOMMA.PRODOTTO che è una funzione in forma di matrice (lavora per intervalli di dati) .

Questa funzione richiede come argomenti delle matrici o intervalli di dati (nel vostra caso gli intervalli A2:A5 eB2:B5), quindi moltiplica fra di loro gli elementi corrispondenti in ciascuna matrice (A2*B2; A3*B3…) e poi somma i risultati ottenuti, esattamente quello che occorre per il calcolo della media ponderata.

La nostra funzione potrà quindi essere semplificata come segue

=MATR.SOMMA.PRODOTTO(A2:A5;B2:B5)/SOMMA(A2:A5)

Attachments:
Download this file (matr somma prodotto.xlsx)matr somma prodotto.xlsx[ ]8 kB
Joomla templates by a4joomla