Questo sito utilizza cookie, anche di terze parti, per migliorare la tua esperienza e offrire servizi in linea con le tue preferenze. Chiudendo questo banner, scorrendo questa pagina o cliccando qualunque suo elemento acconsenti all’uso dei cookie

Rimani informato sugli aggiornamenti di SOS-OFFICE. Inserisci il tuo indirizzo e-mail: Informativa sulla privacy

Oggi voglio vedere come usare la funzione SOMMA.PIÙ.SE (per maggiori info su questa funzione vi consiglio questo video) in unione con la funzione O/OR. Normalmente, infatti le condizioni devono essere verificate tutte e, quindi, risultano unite da E (operatore AND).

Immaginiamo di avere un file come quello della figura (trovate il file di esempio allegato) e di voler sommare le confezioni in magazzino (colonna F) dei prodotti di tipo sferico (colonna D) di colore argento o oro (colonna B)

Nella colonna B non c'è scritto contemporaneamente Oro e Argento, ma uno o l'altro. Come possiamo procedere? Abbiamo due strade:

- eseguire due funzioni SOMMA.PIÙ.SE una per ogni colore e poi sommare i risultati

=SOMMA.PIÙ.SE(F2:F107;D2:D107;"sferico";B2:B107;"oro")+SOMMA.PIÙ.SE(F2:F107;D2:D107;"sferico";B2:B107;"argento")

Finchè le condizioni sono poche, questo approccio va più che bene, ma se i colori che ci interessano fossero una decina?....10 SOMMA.PIÙ.SE sarebbero un po' scomode.....

 

- si potrebbero specificare tutte le condizioni relative alla colonna B in un inico criterio{"oro"\"argento"} in forma di matrice....ma la funzione sommerebbe solo le celle che rispondono al primo criterio. Questo problema si può "superare" con un "trucco": basta racchiudere la funzione SOMMA.PIÙ.SE in una funzione somma ed immetterla in forma di matrice

{=SOMMA(SOMMA.PIÙ.SE(F2:F107;D2:D107;"sferico";B2:B107;{"oro"\"argento"}))}

 

per immettere la funzione come matrice premete contemporaneamente MAIUSC + CTRL + INVIO

 

Per una presentazione della funzione SOMMA.PIÙ.SE fate riferimento all'articolo Video: Excel la funzione SOMMA.PIÙ.SE

 

 

Attachments:
Download this file (sommapiuùseOR.xlsx)sommapiuùseOR.xlsx[ ]12 kB

Commenti   

Max Rotula
#11 Max Rotula 2018-05-16 09:19
Ultima cosa....i criteri tra parentesi graffe vanno scritti in forma testo, non può essere un intervallo di celle?
Citazione
Max Rotula
#10 Max Rotula 2018-05-16 09:18
Perfetto grazie, infatti non avevo capito!
Citazione
Alessandra
#9 Alessandra 2018-05-10 11:40
Citazione Max Rotula:
Ciao Alessandra

Scusa se riapro questa discussione, ma non capisco come inserisci i criteri tra parentesi graffe. Le scrivi a mano? Quelle esterne OK con CTRL+SHIFT+INVIO, ma quelle interne?

Grazie

Quelle interne le devi scrivere tu

AltGr +Shift + è = {
AltGr +Shift + + = }
Citazione
Max Rotula
#8 Max Rotula 2018-05-10 11:35
Ciao Alessandra

Scusa se riapro questa discussione, ma non capisco come inserisci i criteri tra parentesi graffe. Le scrivi a mano? Quelle esterne OK con CTRL+SHIFT+INVI O, ma quelle interne?

Grazie
Citazione
Alessandra
#7 Alessandra 2017-10-09 16:34
Citazione Valter:
Citazione Alessandra:
Innanzi tutto c'è un errore perchè tutti gli intervalli devono essere alti uguali e partire dalla riga 1 o 2. Nel tuo caso, l'intervallo in A parte alla riga 1 e quello in B alla riga 1.
Poi non puoi semplificare così

=SOMMA(SOMMA.PIÙ.SE(A2:A100;A2:A100;">1";B2:B100;{"pippo"\"pluto"\"pippo e pluto"}))

Inserendo in forma di matrice?

Altrimenti la sottrazione mi pare inevitabile

Grazie. Si, l'intervallo era giusto, ho solo sbagliato a scrivere l'1 ed il 2.
Va bene la forma matriciale, ma le celle con riferimento a "pippo e pluto" vengono sommate due volte, quindi in questo modo devo per forza fare anche una sottrazione.


usa la formula che ti ho scritto. non serve fare nessuna sottrazione
Citazione
Valter
#6 Valter 2017-10-09 16:23
Citazione Alessandra:
Innanzi tutto c'è un errore perchè tutti gli intervalli devono essere alti uguali e partire dalla riga 1 o 2. Nel tuo caso, l'intervallo in A parte alla riga 1 e quello in B alla riga 1.
Poi non puoi semplificare così

=SOMMA(SOMMA.PIÙ.SE(A2:A100;A2:A100;">1";B2:B100;{"pippo"\"pluto"\"pippo e pluto"}))

Inserendo in forma di matrice?

Altrimenti la sottrazione mi pare inevitabile

Grazie. Si, l'intervallo era giusto, ho solo sbagliato a scrivere l'1 ed il 2.
Va bene la forma matriciale, ma le celle con riferimento a "pippo e pluto" vengono sommate due volte, quindi in questo modo devo per forza fare anche una sottrazione.
Citazione
Alessandra
#5 Alessandra 2017-10-09 10:30
Citazione Valter:
Ciao. Spero la pagina sia sempre attiva.

Devo sommare tutte i valori delle celle in un intervallo da A2 ad A100 che hanno un valore superiore a 1 e che contengano nell'intervallo da B2 a B100 o il testo "pippo" o il testo "pluto".
Nell'intervallo da B2 a B100 ci sono celle che nel testo hanno solo la parola pippo, altre con solo pluto, altre ancora dove c'è "pippo e pluto" ed anche celle con testi diversi. Quindi bisogna fare attenzione al fatto che le celle che hanno il testo contenente sia pippo che pluto non vengano sommate due volte.

Per ora ho risolto così, ma è poco elegante ;-)

=SOMMA.PIÙ.SE(A2:A100;B1:B100;"*pippo*";A2:A100;">1")+
SOMMA.PIÙ.SE(A2:A100;B1:B100;"*pluto*";A2:A100;">1")-
SOMMA.PIÙ.SE(A2:A100;B1:B100;"*pippo e pluto*";A2:A100;">1")


Innanzi tutto c'è un errore perchè tutti gli intervalli devono essere alti uguali e partire dalla riga 1 o 2. Nel tuo caso, l'intervallo in A parte alla riga 1 e quello in B alla riga 1.
Poi non puoi semplificare così

=SOMMA(SOMMA.PIÙ.SE(A2:A100;A2:A100;">1";B2:B100;{"pippo"\"pluto"\"pippo e pluto"}))

Inserendo in forma di matrice?

Altrimenti la sottrazione mi pare inevitabile
Citazione
Valter
#4 Valter 2017-10-07 09:36
Dimenticavo, la forma {"*pippo*"\"*pl uto*"} non funziona
Citazione
Valter
#3 Valter 2017-10-07 09:23
Ciao. Spero la pagina sia sempre attiva.

Devo sommare tutte i valori delle celle in un intervallo da A2 ad A100 che hanno un valore superiore a 1 e che contengano nell'intervallo da B2 a B100 o il testo "pippo" o il testo "pluto".
Nell'intervallo da B2 a B100 ci sono celle che nel testo hanno solo la parola pippo, altre con solo pluto, altre ancora dove c'è "pippo e pluto" ed anche celle con testi diversi. Quindi bisogna fare attenzione al fatto che le celle che hanno il testo contenente sia pippo che pluto non vengano sommate due volte.

Per ora ho risolto così, ma è poco elegante ;-)

=SOMMA.PIÙ.SE(A2:A100;B1:B100;"*pippo*";A2:A100;">1")+
SOMMA.PIÙ.SE(A2:A100;B1:B100;"*pluto*";A2:A100 ;">1")-
SOMMA.PIÙ.SE(A2:A100;B1:B100;"*pippo e pluto*";A2:A100 ;">1")
Citazione
Alessandra
#2 Alessandra 2017-07-19 15:33
Citazione Vincenzo Giordano:
Ciao Alessandra, perdonami ma sto impazzendo perché non riesco a scrivere la formula matriciale..... :oops: :oops: :oops: .....come devo fare? Non riesco a capire la sequenza di scrittura. Se mi puoi aiutare....grazie


Vincenzo scrivi la formula normalmete, poi, invece di uscire dalla cella con INVIO, premi sulla tastiera CONTEMPORANEAMN TE CTRL + SHIFT + INVIO.
questa operazione la devi rifare ogni volta che modifichi la formula
Citazione
Joomla templates by a4joomla