Questo sito utilizza cookie, anche di terze parti, per migliorare la tua esperienza e offrire servizi in linea con le tue preferenze. Chiudendo questo banner, scorrendo questa pagina o cliccando qualunque suo elemento acconsenti all’uso dei cookie

Stampa

Nell’ultimo video che ho postato ho parlato di tabelle. Ne avevo già parlato in un altro video e devo dire che io le uso moltissimo e le trovo davvero comode.

Hanno solo un piccolo, ma noioso difetto: se si trascina in orizzontale una formula che usa una colonna di tabella, questa non è un riferimento assoluto, ma si aggiorna con il trascinamento.

 

Immaginiamo di avere questa tabella il cui nome è elencoComuni

 

Contiene l’elenco dei comuni d’Italia. Ora, vogliamo contare quanti comuni ha ciascuna regione. Se lo facciamo in verticale, nessun problema, ma se lo facciamo in orizzontale… le cose non sono altrettanto facili.

 

La formula in A2 è

=CONTA.SE(elencoComuni[Regione];A1)

Se trasciniamo a destra questa formula… nella colonna B diventa

=CONTA.SE(elencoComuni[Prefisso];B1)

Perché Prefisso è la colonna alla destra di Regione nella tabella.

Naturalmente il problema si presenta in tutte le colonne.

Purtroppo non c’è modo per bloccare in valore assoluto i riferimenti alle colonne di tabella, il che è un vero peccato.

Una soluzione, però, c’è ed è quella di usare la funzione INDIRETTO per costruire il riferimento.

INDIRETTO crea un riferimento a partire dal testo che le viene passato come argomento. Bisogna quindi correggere la formula come segue

=CONTA.SE(INDIRETTO("elencoComuni[Regione]");A1)

Il riferimento creato con INDIRETTO non si aggiorna nel trascinamento, ma rimane, per così dire, bloccato in valore assoluto.

Attachments:
Download this file (indirettoPerTabelle.xlsx)indirettoPerTabelle.xlsx[ ]538 kB