Questo sito utilizza cookie, anche di terze parti, per migliorare la tua esperienza e offrire servizi in linea con le tue preferenze. Chiudendo questo banner, scorrendo questa pagina o cliccando qualunque suo elemento acconsenti all’uso dei cookie

Rimani informato sugli aggiornamenti di SOS-OFFICE. Inserisci il tuo indirizzo e-mail: Informativa sulla privacy

Un utente di SOS-office ci ha chiesto come individuare in un gruppo di celle di un foglio Excel i tre valori più piccoli. Ci è sembrato un argomento di interesse generale e così abbiamo pensato di dedicargli un intero post.

 

Partiamo con una situazione come quella che vedete nella figura sotto

Per evidenziare i tre valori più piccoli dell'intervallo A3:J3 possiamo ricorrere alla formattazione condizionale.

Dopo aver selezionato l'intervallo, nel gruppo Stili della scheda Home, fate clic sul Formattazione condizionale.

Quindi scegliete Regole Primi/Ultimi > Ultimi 10 elementi. Nella nuova finestra scegliete di evidenziare gli ultimi tre elementi e poi scegliete la formattazione che desiderate applicare.

Naturalmente, con la regola Primi 10 elementi, potete evidenziare i valori più grandi dell'intervallo

Questo per evidenziare i valori. Se volete escludere dai conteggi i tre valori più piccoli, potete ricorrere alla funzione PICCOLO() che, dato un intervallo, restituisce il k-esimo valore più piccolo di quell'intervallo.

Ad esempio

=PICCOLO($A$3:$J$3;3)

Restituisce il terzo valore più piccolo dell'intervallo A3:J3.

Analogamente,

=GRANDE($A$3:$J$3;3)

Restituisce il terzo valore più grande dell'intervallo A3:J3.

Allora, se volessimo sommare i valori dell'intervallo A3:J3 ad esclusione di tre più piccoli, potremmo usare, indifferentemente una delle seguenti formule

=SOMMA(GRANDE($A$3:$J$3;1);GRANDE($A$3:$J$3;2);GRANDE($A$3:$J$3;3);GRANDE($A$3:$J$3;4);GRANDE($A$3:$J$3;5);GRANDE($A$3:$J$3;6);GRANDE($A$3:$J$3;7))
=SOMMA(A3:J3)-PICCOLO($A$3:$J$3;1)-PICCOLO($A$3:$J$3;2)-PICCOLO($A$3:$J$3;3)

La prima formula somma i sette valori più grandi dell'intervallo, la seconda somma tutti i valori dell'intervallo poi sottrae i tre più piccoli

Joomla templates by a4joomla